
<!doctype html>
<html class="no-js" lang="">
<head>
<meta charset="utf-8">
<meta http-equiv="x-ua-compatible" content="ie=edge">
<title>Sacha Baron Cohen to Receive Comedic Genius Honor at 2021 MTV Movie and TV Awards</title>
<meta name="description" content="The 'Borat Subsequent Moviefilm' actor has been officially announced as a special honoree at the upcoming MTV Movie and TV awards which will be hosted by Leslie Jones. " />
<meta name="keywords" content="Sacha Baron Cohen,2021 MTV Movie and TV Awards,Comedic Genius Award" />
<meta name="news_keywords" content="Sacha Baron Cohen,2021 MTV Movie and TV Awards,Comedic Genius Award" />
<meta name="author" content="WENN" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta http-equiv="Pragma" content="no-cache" />
<meta http-equiv="Cache-Control" content="no-cache" />
<meta http-equiv="Expires" content="Wed, 17 Aug 2016 05:00:00 GMT" />
<meta http-equiv="content-language" content="en-us, en-gb, en-au, en-ca" />

<meta property="fb:app_id" content=320088948016615 />
<meta property="og:title" content="Sacha Baron Cohen to Receive Comedic Genius Honor at 2021 MTV Movie and TV Awards" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.aceshowbiz.com/news/view/00170526.html" />
<meta property="og:image" content="https://www.aceshowbiz.com/display/images/photo/2021/05/08/00170526.jpg" />
<meta property="og:site_name" content="AceShowbiz" />
<meta property="og:description" content="The 'Borat Subsequent Moviefilm' actor has been officially announced as a special honoree at the upcoming MTV Movie and TV awards which will be hosted by Leslie Jones." />
<meta property="og:image:alt" content="Sacha Baron Cohen to Receive Comedic Genius Honor at 2021 MTV Movie and TV Awards" />

<meta name="twitter:title" content="Sacha Baron Cohen to Receive Comedic Genius Honor at 2021 MTV Movie and TV Awards" />
<meta name="twitter:description" content="The 'Borat Subsequent Moviefilm' actor has been officially announced as a special honoree at the upcoming MTV Movie and TV awards which will be hosted by Leslie Jones." />
<meta name="twitter:image" content="https://www.aceshowbiz.com/display/images/photo/2021/05/08/00170526.jpg" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@aceshowbiz">
<meta name="twitter:creator" content="@aceshowbiz">
<meta name="twitter:domain" content="aceshowbiz.com">
<meta name="robots" content="index, follow" />
<meta name="Googlebot-news" content="index, follow" />

<script type="application/ld+json">
		{
			"@context": "http://schema.org",
			"@type": "NewsArticle",
			"mainEntityOfPage": 
			{
				"@type": "WebPage",
				"@id": "https://www.aceshowbiz.com/news/view/00170526.html"
			},
			"headline": "Sacha Baron Cohen to Receive Comedic Genius Honor at 2021 MTV Movie and TV Awards",
			"description": "The 'Borat Subsequent Moviefilm' actor has been officially announced as a special honoree at the upcoming MTV Movie and TV awards which will be hosted by Leslie Jones.",			
			"image": {
				"@type": "ImageObject",
				"url": "https://www.aceshowbiz.com/display/images/photo/2021/05/08/00170526.jpg",
				"height": 1280,
				"width": 800			},			
			"datePublished": "2021-05-08 05:00:01",
			"dateModified": "2021-05-08 05:00:01",
						"author": {
				"@type": "Person",
				"name": "WENN"
			},
			"publisher": {
				"@type": "Organization",
				"name": "AceShowbiz.com",
				"logo": {
					"@type": "ImageObject",
					"url": "https://www.aceshowbiz.com/assets/img/png/logo225x30.png",
					"width": 225,
					"height": 30
				}
			}
		}
		</script>
<script type="application/ld+json">
		{
		  "@context": "http://schema.org",
		  "@type": "WebPage",
		  "headline": "Sacha Baron Cohen to Receive Comedic Genius Honor at 2021 MTV Movie and TV Awards",
		  "url": "https://www.aceshowbiz.com/news/view/00170526.html",
		  "datePublished": "2021-05-08 05:00:01",
		  "image": "https://www.aceshowbiz.com/display/images/photo/2021/05/08/00170526.jpg",
		  "thumbnailUrl" : "https://www.aceshowbiz.com/display/images/150x200/2021/05/08/00170526.jpg"
		}
		</script>
<link rel="alternate" media="only screen and (max-width: 600px)" href="https://m.aceshowbiz.com/news/view/00170526.html">
<link rel="amphtml" href="https://www.aceshowbiz.com/amp/news/view/00170526.html" />

<link rel="stylesheet" href="/assets/css/normalize.css">

<link rel="stylesheet" href="/assets/css/main.css">

<link rel="stylesheet" href="/assets/css/bootstrap.min.css">



<link rel="stylesheet" href="/assets/css/font-awesome.min.css">


<link rel="stylesheet" href="/assets/css/meanmenu.min.css">





<link rel="stylesheet" href="/assets/css/style.css?v=1.12">

<link rel="stylesheet" type="text/css" href="/assets/css/ie-only.css" />

<script src="/assets/js/modernizr-2.8.3.min.js"></script>
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black">
<meta name="theme-color" content="#5F256F">
<link rel="manifest" href="/manifest.json">

<link rel="shortcut icon" type="image/x-icon" href="/assets/img/gif/favicon.gif">
<link rel="icon" sizes="192x192" href="/assets/img/png/icon192.png">

<link rel="apple-touch-icon" sizes="57x57" href="https://www.aceshowbiz.com/assets/img/png/icon57.png">

<link rel="apple-touch-icon" sizes="76x76" href="https://www.aceshowbiz.com/assets/img/png/icon76.png">

<link rel="apple-touch-icon" sizes="120x120" href="https://www.aceshowbiz.com/assets/img/png/icon120.png">

<link rel="apple-touch-icon" sizes="152x152" href="https://www.aceshowbiz.com/assets/img/png/icon152.png">

<link rel="apple-touch-icon" sizes="167x167" href="https://www.aceshowbiz.com/assets/img/png/icon167.png">

<link rel="apple-touch-icon" sizes="180x180" href="https://www.aceshowbiz.com/assets/img/png/icon180.png">

<link rel="icon" sizes="192x192" href="https://www.aceshowbiz.com/assets/img/png/icon192.png">

<link rel="icon" sizes="128x128" href="https://www.aceshowbiz.com/assets/img/png/icon128.png">

<link rel="icon" sizes="128x128" href="https://www.aceshowbiz.com/assets/img/png/icon128.png">
<link rel="dns-prefetch" href="//whizzco.com">
<link rel="dns-prefetch" href="//facebook.net">
<link rel="dns-prefetch" href="//sharethis.com">
<link rel="dns-prefetch" href="//mgid.com">
<link rel="dns-prefetch" href="//googlesyndication.com">
<link rel="dns-prefetch" href="//google-analytics.com">
<link rel="dns-prefetch" href="https://certify-js.alexametrics.com">
<link rel="dns-prefetch" href="https://tpc.googlesyndication.com">
<link rel="dns-prefetch" href="https://pagead2.googlesyndication.com">

<script>
		  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

		  ga('create', 'UA-4375969-1', 'aceshowbiz.com');
		  ga('require', 'displayfeatures');
		  ga('send', 'pageview');

		</script>


<script src="/assets/js/modernizr-2.8.3.min.js"></script>

<script src="/assets/js/jquery-2.2.4.min.js" type="text/javascript"></script>

<script async src="/assets/js/plugins.js " type="text/javascript"></script>


<script async src="/assets/js/bootstrap.min.js " type="text/javascript"></script>



<script src="/assets/js/jquery.meanmenu.min.js " type="text/javascript"></script>

<script src="/assets/js/jquery.scrollUp.min.js " type="text/javascript"></script>



<script async src="/assets/js/jquery.magnific-popup.min.js"></script>


<script defer src="/assets/js/main.js?v=10" type="text/javascript"></script>

<script type="text/javascript" src="//monu.delivery/site/e/b/2bf27f-17e2-40d0-a441-9692d87ef2ed.js" data-cfasync="false"></script>
<style>
			.videoWrapper {
				position: relative;
				padding-bottom: 56.25%; /* 16:9 */
				padding-top: 25px;
				height: 0;
			}
			.videoWrapper iframe {
				position: absolute;
				top: 0;
				left: 0;
				width: 100%;
				height: 100%;
			}
			.videoWrapper object {
				position: absolute;
				top: 0;
				left: 0;
				width: 100%;
				height: 100%;
			}			
		</style>
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body>
<!--[if lt IE 8]>
    <p class="browserupgrade">You are using an 
        <strong>outdated</strong> browser. Please 
        <a href="https://www.google.com/chrome/">upgrade your browser</a> to improve your experience.
    </p>
    <![endif]-->

<div id="wrapper" class="wrapper">

<header>
<div id="header-layout1" class="header-style1">
<div class="main-menu-area bg-primarytextcolor header-menu-fixed" id="sticker">
<div class="container">
<div class="row no-gutters d-flex align-items-center">
<div class="col-lg-2 d-none d-lg-block">
<div class="logo-area">
<a href="/">
<img src="/assets/img/logo.png" alt="AceShowbiz logo" class="/assets/img-fluid">
</a>
</div>
</div>
<div class="col-xl-8 col-lg-7 position-static min-height-none">
<div class="ne-main-menu">
<nav id="dropdown">
<ul>
<li>
<a href="/" title="Home">
<strong>Home</strong>
</a>
</li>
<li>
<a href="/news/" title="News">
<strong>News</strong>
</a>
<ul class="ne-dropdown-menu">
<li>
<a href="/news/celebrity/" title="Celebrity News">
Celebrity News
</a>
</li>
<li>
<a href="/news/movie/" title="Movie News">
Movie News
</a>
</li>
<li>
<a href="/news/tv/" title="TV News">
TV News
</a>
</li>
<li>
<a href="/news/music/" title="Music News">
Music News
</a>
</li>

</ul>
</li>
<li>
<a href="/celebrity/" title="Celebrity">
<strong>Celebrity</strong>
</a>
<ul class="ne-dropdown-menu">
<li>
<a href="/celebrity/buzz/" title="The Buzz">
The Buzz
</a>
</li>
<li>
<a href="/celebrity/legends/" title="The Legend">
The Legends
</a>
</li>
<li>
<a href="/celebrity/teenage/" title="Young Celeb">
Young Celeb
</a>
</li>
</ul>
</li>
<li>
<a href="/movie/" title="Movie">
<strong>Movie</strong>
</a>
<ul class="ne-dropdown-menu">
<li>
<a href="/movie/chart/" title="U.S. Box Office">
U.S. Box Office
</a>
</li>
<li>
<a href="/movie/now_playing/" title="Now Playing">
Now Playing
</a>
</li>
<li>
<a href="/movie/coming_soon/" title="Coming Soon">
Coming Soon
</a>
</li>
<li>
<a href="/movie/trailer/" title="Trailers">
Trailers
</a>
</li>
<li>
<a href="/movie/stills/" title="Pictures">
Pictures
</a>
</li>
<li>
<a href="/movie/review/" title="Reviews">
Reviews
</a>
</li>
<li>
<a href="/movie/soundtrack/" title="Soundtrack">
Soundtrack
</a>
</li>
</ul>
</li>
<li>
<a href="/tv/" title="TV">
<strong>TV</strong>
</a>
<ul class="ne-dropdown-menu">
<li>
<a href="/tv/trailer/" title="TV Clip / Previews">
TV Clip / Previews
</a>
</li>
<li>
<a href="/tv/dvd/" title="TV on DVD">
TV on DVD
</a>
</li>
<li>
<a href="/tv/soundtrack/" title="Soundtrack">
Soundtrack
</a>
</li>
</ul>
</li>
<li>
<a href="/music/" title="Music">
<strong>Music</strong>
</a>
<ul class="ne-dropdown-menu">
<li>
<a href="/music/artist/" title="Artist of The Week">
Artist of The Week
</a>
</li>
<li>
<a href="/music/chart/" title="ASB Music Chart">
ASB Music Chart
</a>
</li>
<li>
<a href="/music/new_release/" title="New Release">
New Release
</a>
</li>
<li>
<a href="/music/video/" title="Music Video">
Music Video
</a>
</li>
</ul>
</li>
<li>
<a href="/gallery/" title="Photo">
<strong>Photo</strong>
</a>
</li>
<li>
<a href="/video/" title="Video">
<strong>Video</strong>
</a>
<ul class="ne-dropdown-menu">
<li>
<a href="/music/video/" title="Music Video">
Music Video
</a>
</li>
<li>
<a href="/movie/trailer/" title="Movie Trailer">
Movie Trailer
</a>
</li>
<li>
<a href="/tv/trailer/" title="TV Clip">
TV Clip
</a>
</li>
</ul>
</li>
<li>
<a href="#" title="Other">
<strong>Other</strong>
</a>
<ul class="ne-dropdown-menu">
<li>
<a href="/interviews/" title="Interviews">
<strong>Interviews</strong>
</a>
</li>
<li>
<a href="/movie/dvd/" title="DVD">
<strong>DVD</strong>
</a>
</li>
<li>
<a href="/contest/" title="Contest">
<strong>Contest</strong>
</a>
</li>
<li>
<a href="/index_old.php" title="Old Homepage">
<strong>Old Homepage</strong>
</a>
</li>
</ul>
</li>
</ul>
</nav>
</div>
</div>
<div class="col-xl-2 col-lg-3 col-md-12 text-right position-static">
<div class="header-action-item">
<ul>
<li>
<form id="top-search-form" class="header-search-light">
<input type="text" class="search-input" placeholder="Search...." required="" style="display: none;">
<button class="search-button">
<i class="fa fa-search" aria-hidden="true"></i>
</button>
&nbsp;&nbsp;
</form>
</li>
 </ul>
</div>
</div>
</div>
</div>
</div>
</div>
</header>

<div class="container">&nbsp;</div>
<div class="mt-30">&nbsp;</div>
<style>
			#RightFloatAds
			{
			right: 0px;
			position: fixed;
			top: 84px;
			z-index:2;
			}
		</style>
<div id="RightFloatAds">

<div id="mmt-38210595-845a-4977-bbb3-b331b80feb28"></div><script type="text/javascript" data-cfasync="false">$MMT = window.$MMT || {}; $MMT.cmd = $MMT.cmd || [];$MMT.cmd.push(function(){ $MMT.display.slots.push(["38210595-845a-4977-bbb3-b331b80feb28"]); })</script>

</div>

<section class="breadcrumbs-area" style="background-image: url('/assets/img/banner/breadcrumbs-banner.jpg');">
<div class="container">
<div class="breadcrumbs-content">
<h1>Sacha Baron Cohen to Receive Comedic Genius Honor at 2021 MTV Movie and TV Awards</h1>
<ul>
<li><a href="/">Home</a> -</li>
<li><a href="/news/">News</a></li>
</ul>
</div>
</div>
</section>


<section class="bg-body">
<div class="container">
<div class="row">
<div class="col-12">
<div class="ne-banner-layout1 mt-30 mb-30 text-center">

<div id="mmt-46d61155-bd2e-4ebb-9d2c-5362c0c1b876"></div><script type="text/javascript" data-cfasync="false">$MMT = window.$MMT || {}; $MMT.cmd = $MMT.cmd || [];$MMT.cmd.push(function(){ $MMT.display.slots.push(["46d61155-bd2e-4ebb-9d2c-5362c0c1b876"]); })</script>

</div>
</div>
</div>
</div>
</section>


<section class="bg-body section-space-less30">
<div class="container">
<div class="row">

<div class="col-lg-8 col-md-12 mb-30">
<div class="news-details-layout1">

<div class="position-relative mb-30">
<figure>
<img src="/display/images/photo/2021/05/08/00170526.jpg" alt="Sacha Baron Cohen to Receive Comedic Genius Honor at 2021 MTV Movie and TV Awards" class="img-fluid width-100">
<figcaption><i>WENN</i></figcaption>
</figure>
<div class="topic-box-top-sm">
<div class="topic-box-sm color-cinnabar mb-20">Movie</div>
</div>
</div>

<h2 class="title-semibold-dark size-c30">The 'Borat Subsequent Moviefilm' actor has been officially announced as a special honoree at the upcoming MTV Movie and TV awards which will be hosted by Leslie Jones.</h2>

<section class="bg-body">
<div class="container">
<div class="row">
<div class="col-12">
<div class="ne-banner-layout1 mb-20 text-center">
</div>
</div>
</div>
</div>
</section>

<ul class="post-info-dark mb-30">
<li>
<i class="fa fa-calendar" aria-hidden="true"></i> May 8, 2021 </li>
</ul>

<p><strong>AceShowbiz</strong> -
<strong><a href="/celebrity/sacha_baron_cohen/">Sacha Baron Cohen</a></strong> will be honoured with the Comedic Genius Award at the MTV Movie &amp; TV Awards.
</p>
<p>
The "<strong><a href="/movie/borat/">Borat</a></strong>" actor is set to become only the fourth-ever recipient of the prize as he follows on from <strong><a href="/celebrity/will_ferrell/">Will Ferrell</a></strong>, <strong><a href="/celebrity/kevin_hart/">Kevin Hart</a></strong>, and <strong><a href="/celebrity/melissa_mccarthy/">Melissa McCarthy</a></strong>.
</p>
<p>
MTV chose Sacha for the award because they wanted to honour "an actor who has made incomparable contributions to the world of comedy, providing a major influence through their work and transforming the genre at large."
</p>
<p>
The "<strong><a href="/movie/bruno/">Bruno</a></strong>" star will be recognised on May 16 while he is also nominated in three categories at the ceremony, which will be held at the Palladium in Los Angeles
</p><p>

<div id="M679263ScriptRootC1107244">
</div>
<script src="https://jsc.mgid.com/a/c/aceshowbiz.com.1107244.js" async></script>

</p><p>
<div class="author-info p-10-r see-also mb-30 border-all">
<div class="see-also-title">&nbsp; See also...</div>
<ul class="fa-ul see-also-ul">
<li class="see-also-li">
<i class="fa-li top03em fa fa-arrow-right"></i>
<a href="/news/view/00170502.html">Dave Bautista Justifies Giving Up on 'Suicide Squad' for Zack Snyder's 'Army of the Dead'</a>
</li>
<li class="see-also-li">
<i class="fa-li top03em fa fa-arrow-right"></i>
<a href="/news/view/00170506.html">Dave Bautista May Bid Farewell to Drax in 'Guardians of the Galaxy Vol. 3'</a>
</li>
<li class="see-also-li">
<i class="fa-li top03em fa fa-arrow-right"></i>
<a href="/news/view/00170497.html">'A Quiet Place Part II' Raises the Stakes in Final Trailer</a>
</li>
<li class="see-also-li">
<i class="fa-li top03em fa fa-arrow-right"></i>
<a href="/news/view/00170462.html">Diane Warren Getting Her Own Documentary Movie</a>
</li>
</ul>
</div>
</p><p>

<section class="bg-body">
<div class="container">
<div class="row">
<div class="col-12">
<div class="ne-banner-layout1 mt-20 mb-30 text-center">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-5315453046799966" data-ad-slot="2208110885"></ins>
<script>
				 (adsbygoogle = window.adsbygoogle || []).push({});
			</script>
</div>
</div>
</div>
</div>
</section>


</p><p>
</p>
<p>
"<strong><a href="/movie/borat_subsequent_moviefilm/">Borat Subsequent Moviefilm</a></strong>" is in the running for best movie while he and co-star <strong><a href="/celebrity/maria_bakalova/">Maria Bakalova</a></strong> have been listed for best duo.
</p>
<p>
The star is also on the shortlist for best performance in a movie for his role in "<strong><a href="/movie/trial_of_the_chicago_7_the/">The Trial of the Chicago 7</a></strong>".
</p>
<p>
<strong><a href="/celebrity/leslie_jones/">Leslie Jones</a></strong> will host the main ceremony as MTV celebrates the biggest moments in film and television over the past year.
</p>
<p>
The following night, <strong><a href="/celebrity/nikki_glaser/">Nikki Glaser</a></strong> will host the first-ever "<strong>MTV Movie &amp; TV Awards: Unscripted</strong>", which will honour the best in reality TV.
</p>
<p>
Leslie Jones herself is up for Best Comedic Performance, thanks to her onscreen role in "<strong><a href="/movie/coming_2_america/">Coming 2 America</a></strong>". The "<strong><a href="/tv/saturday_night_live/">Saturday Night Live</a></strong>" star is pitted against <strong><a href="/celebrity/eric_andre/">Eric Andre</a></strong> ("<strong><a href="/movie/bad_trip/">Bad Trip</a></strong>)", <strong><a href="/celebrity/annie_murphy/">Annie Murphy</a></strong> ("<strong><a href="/tv/schitt_s_creek/">Schitt's Creek</a></strong>"), <strong><a href="/celebrity/issa_rae/">Issa Rae</a></strong> ("<strong><a href="/tv/insecure/">Insecure</a></strong>"), and <strong><a href="/celebrity/jason_sudeikis/">Jason Sudeikis</a></strong> ("<strong><a href="/tv/ted_lasso/">Ted Lasso</a></strong>").
</p>


<div class="mb-30">

<section class="bg-body">
<div class="container">
<div class="row">
<div class="col-12">
<div class="ne-banner-layout1 mt-20 text-center">

<div id="M679263ScriptRootC1077402">
</div>
<script src="https://jsc.mgid.com/a/c/aceshowbiz.com.1077402.js" async></script>

</div>
</div>
</div>
</div>
</section>

</div>
<div class="post-share-area mb-40 item-shadow-1">
<p>You can share this post!</p>
<div class="sharethis-inline-share-buttons"></div>
</div>
<div class="row no-gutters divider blog-post-slider">
<div class="col-lg-6 col-md-6 col-sm-6 col-6">
<a href="/news/view/00170525.html" class="prev-article">
<i class="fa fa-angle-left" aria-hidden="true"></i>Previous article</a>
<a href="/news/view/00170525.html"><h3 class="title-medium-dark pr-50">Pete Davidson Hates 'Playing Games' in Relationships, Prefers to be Open About His Issues</h3></a>
</div>
<div class="col-lg-6 col-md-6 col-sm-6 col-6 text-right">
<a href="/news/view/00170527.html" class="next-article">Next article
<i class="fa fa-angle-right" aria-hidden="true"></i>
</a>
<a href="/news/view/00170527.html"><h3 class="title-medium-dark pl-50">Chris Cornell's Widow and Doctor Reach Settlement in Legal Feud Over Prescribed Drugs </h3></a>
</div>
</div>
<section>
 
<div class="row">
<div class="col-12">
<div class="topic-border color-cod-gray mb-30 width-100">
<div class="topic-box-lg color-cod-gray">Related Posts</div>
</div>
</div>
</div>
<div class="row">
<div class="col-lg-6 col-md-6 col-sm-6 col-6">
<div class="media mb-30">
<a class="width38-lg width40-md img-opacity-hover" href="/news/view/00166487.html">
<img src="/display/images/90x60/2021/02/14/00166487.jpg" data-qazy="true" alt="Sacha Baron Cohen Failed to Buy Peter Sellers' Golden Globe at Auction" class="img-fluid">
</a>
<div class="media-body">
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00166487.html">Sacha Baron Cohen Failed to Buy Peter Sellers' Golden Globe at Auction</a>
</h3>
</div>
</div>
</div>
<div class="col-lg-6 col-md-6 col-sm-6 col-6">
<div class="media mb-30">
<a class="width38-lg width40-md img-opacity-hover" href="/news/view/00165784.html">
<img src="/display/images/90x60/2021/01/29/00165784.jpg" data-qazy="true" alt="Sacha Baron Cohen Is Special Honoree at Santa Barbara Film Festival" class="img-fluid">
</a>
<div class="media-body">
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00165784.html">Sacha Baron Cohen Is Special Honoree at Santa Barbara Film Festival</a>
</h3>
</div>
</div>
</div>
<div class="col-lg-6 col-md-6 col-sm-6 col-6">
<div class="media mb-30">
<a class="width38-lg width40-md img-opacity-hover" href="/news/view/00164803.html">
<img src="/display/images/90x60/2021/01/07/00164803.jpg" data-qazy="true" alt="Sacha Baron Cohen Has No Plan to Make Third 'Borat' Movie" class="img-fluid">
</a>
<div class="media-body">
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00164803.html">Sacha Baron Cohen Has No Plan to Make Third 'Borat' Movie</a>
</h3>
</div>
</div>
</div>
<div class="col-lg-6 col-md-6 col-sm-6 col-6">
<div class="media mb-30">
<a class="width38-lg width40-md img-opacity-hover" href="/news/view/00162277.html">
<img src="/display/images/90x60/2020/11/09/00162277.jpg" data-qazy="true" alt="Sacha Baron Cohen Mocks Donald Trump for 'Tragic and Sad' Response to Election Defeat" class="img-fluid">
</a>
<div class="media-body">
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00162277.html">Sacha Baron Cohen Mocks Donald Trump for 'Tragic and Sad' Response to Election Defeat</a>
</h3>
</div>
</div>
</div>
</div>

</section>
</div>
</div>


<div class="ne-sidebar sidebar-break-md col-lg-4 col-md-12">

<div class="sidebar-box">

<ul class="stay-connected overflow-hidden">
<li class="facebook">
<a href="https://www.facebook.com/aceshowbizdotcom/">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
</a>
</li>
<li class="twitter">
<a href="https://twitter.com/aceshowbiz/">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
</li>
<li class="google_plus">
<a href="https://plus.google.com/117276967966258729454">
<i class="fa fa-google-plus" aria-hidden="true"></i>
</a>
</li>
<li class="rss">
<a href="/site/rss.php">
<i class="fa fa-rss" aria-hidden="true"></i>
</a>
</li>
</ul>
</div>

<div class="sidebar-box">
<div class="ne-banner-layout1 text-center">

<div id="mmt-9c115838-b3b1-4334-9122-dba58b21c996"></div><script type="text/javascript" data-cfasync="false">$MMT = window.$MMT || {}; $MMT.cmd = $MMT.cmd || [];$MMT.cmd.push(function(){ $MMT.display.slots.push(["9c115838-b3b1-4334-9122-dba58b21c996"]); })</script>

</div>
</div>
<div class="sidebar-box">
<div class="topic-border color-scampi mb-5">
<div class="topic-box-lg color-scampi">Most Read</div>
</div>
<div class="row">
<div class="col-12">
<div class="img-overlay-70 img-scale-animate mb-30">
<a href="/news/view/00170375.html"><img src="/display/images/300x400/2021/05/05/00170375.jpg" data-qazy="true" alt="Tribeca Film Festival Reveals Jason Reitman Interview Among Its Inaugural Podcasts Program" data-qazy="true" class="img-fluid width-100"></a>
<div class="topic-box-top-lg">
<div class="topic-box-sm color-cod-gray mb-20">Movie</div>
</div>
<div class="mask-content-lg">
<div class="post-date-light">
<ul>
<li>
<span>
<i class="fa fa-calendar" aria-hidden="true"></i>
</span></li>
</ul>
</div>
<h2 class="title-medium-light size-lg">
<a href="/news/view/00170375.html">Tribeca Film Festival Reveals Jason Reitman Interview Among Its Inaugural Podcasts Program</a>
</h2>
</div>
</div>
</div>
<div class="col-lg-6 col-md-6 col-sm-4 col-6">
<div class="mt-25">
<a href="/news/view/00170416.html" class="img-opacity-hover">
<img src="/display/images/160x117/2021/05/06/00170416.jpg" data-qazy="true" alt="Amy Adams and Jake Gyllenhaal Team Up for True-Story Movie 'Finding the Mother Tree'" class="img-fluid mb-10 width-100">
</a>
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00170416.html">Amy Adams and Jake Gyllenhaal Team Up for True-Story Movie 'Finding the Mother Tree'</a>
</h3>
</div>
 </div>
<div class="col-lg-6 col-md-6 col-sm-4 col-6">
<div class="mt-25">
<a href="/news/view/00170374.html" class="img-opacity-hover">
<img src="/display/images/160x117/2021/05/05/00170374.jpg" data-qazy="true" alt="Billie Lourd Marks 'Star Wars' Day by Dressing Baby Boy in Princess Leia Onesie" class="img-fluid mb-10 width-100">
</a>
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00170374.html">Billie Lourd Marks 'Star Wars' Day by Dressing Baby Boy in Princess Leia Onesie</a>
</h3>
</div>
</div>
<div class="col-lg-6 col-md-6 col-sm-4 col-6">
<div class="mt-25">
<a href="/news/view/00170417.html" class="img-opacity-hover">
<img src="/display/images/160x117/2021/05/06/00170417.jpg" data-qazy="true" alt="Pete Davidson Gets His Tattoos Removed to Win More Movie Roles" class="img-fluid mb-10 width-100">
</a>
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00170417.html">Pete Davidson Gets His Tattoos Removed to Win More Movie Roles</a>
</h3>
</div>
</div>
<div class="col-lg-6 col-md-6 col-sm-4 col-6">
<div class="mt-25">
<a href="/news/view/00170377.html" class="img-opacity-hover">
<img src="/display/images/160x117/2021/05/05/00170377.jpg" data-qazy="true" alt="Andrew Garfield Says Rumors About Him Returning to 'Spider-Man: No Way Home' Is 'F**king Hilarious'" class="img-fluid mb-10 width-100">
</a>
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00170377.html">Andrew Garfield Says Rumors About Him Returning to 'Spider-Man: No Way Home' Is 'F**king Hilarious'</a>
</h3>
</div>
</div>
<div class="col-lg-6 col-md-6 col-sm-4 col-6">
<div class="mt-25">
<a href="/news/view/00170431.html" class="img-opacity-hover">
<img src="/display/images/160x117/2021/05/06/00170431.jpg" data-qazy="true" alt="WB 'Committed' to Hiring Black Director and Black Actor for New Superman Movie" class="img-fluid mb-10 width-100">
</a>
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00170431.html">WB 'Committed' to Hiring Black Director and Black Actor for New Superman Movie</a>
</h3>
</div>
</div>
<div class="col-lg-6 col-md-6 col-sm-4 col-6">
<div class="mt-25">
<a href="/news/view/00170439.html" class="img-opacity-hover">
<img src="/display/images/160x117/2021/05/06/00170439.jpg" data-qazy="true" alt="New 'The Batman' Leaked Video Sees Catwoman in Action" class="img-fluid mb-10 width-100">
</a>
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00170439.html">New 'The Batman' Leaked Video Sees Catwoman in Action</a>
</h3>
</div>
</div>
<div class="col-lg-6 col-md-6 col-sm-4 col-6">
<div class="mt-25">
<a href="/news/view/00170462.html" class="img-opacity-hover">
<img src="/display/images/160x117/2021/05/07/00170462.jpg" data-qazy="true" alt="Diane Warren Getting Her Own Documentary Movie" class="img-fluid mb-10 width-100">
</a>
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00170462.html">Diane Warren Getting Her Own Documentary Movie</a>
</h3>
</div>
</div>
<div class="col-lg-6 col-md-6 col-sm-4 col-6">
<div class="mt-25">
<a href="/news/view/00170497.html" class="img-opacity-hover">
<img src="/display/images/160x117/2021/05/07/00170497.jpg" data-qazy="true" alt="'A Quiet Place Part II' Raises the Stakes in Final Trailer" class="img-fluid mb-10 width-100">
</a>
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00170497.html">'A Quiet Place Part II' Raises the Stakes in Final Trailer</a>
</h3>
</div>
</div>
<div class="col-lg-6 col-md-6 col-sm-4 col-6">
<div class="mt-25">
<a href="/news/view/00170506.html" class="img-opacity-hover">
<img src="/display/images/160x117/2021/05/07/00170506.jpg" data-qazy="true" alt="Dave Bautista May Bid Farewell to Drax in 'Guardians of the Galaxy Vol. 3'" class="img-fluid mb-10 width-100">
</a>
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00170506.html">Dave Bautista May Bid Farewell to Drax in 'Guardians of the Galaxy Vol. 3'</a>
</h3>
</div>
</div>
<div class="col-lg-6 col-md-6 col-sm-4 col-6">
<div class="mt-25">
<a href="/news/view/00170461.html" class="img-opacity-hover">
<img src="/display/images/160x117/2021/05/07/00170461.jpg" data-qazy="true" alt="Tiffany Haddish Struggled to Cry on Cue for New Movie as She Trained Herself to Turn Tears Into Joke" class="img-fluid mb-10 width-100">
</a>
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00170461.html">Tiffany Haddish Struggled to Cry on Cue for New Movie as She Trained Herself to Turn Tears Into Joke</a>
</h3>
</div>
</div>
<div class="col-lg-6 col-md-6 col-sm-4 col-6">
<div class="mt-25">
<a href="/news/view/00170502.html" class="img-opacity-hover">
<img src="/display/images/160x117/2021/05/07/00170502.jpg" data-qazy="true" alt="Dave Bautista Justifies Giving Up on 'Suicide Squad' for Zack Snyder's 'Army of the Dead'" class="img-fluid mb-10 width-100">
</a>
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00170502.html">Dave Bautista Justifies Giving Up on 'Suicide Squad' for Zack Snyder's 'Army of the Dead'</a>
</h3>
</div>
</div>
<div class="col-lg-6 col-md-6 col-sm-4 col-6">
<div class="mt-25">
<a href="/news/view/00170526.html" class="img-opacity-hover">
<img src="/display/images/160x117/2021/05/08/00170526.jpg" data-qazy="true" alt="Sacha Baron Cohen to Receive Comedic Genius Honor at 2021 MTV Movie and TV Awards" class="img-fluid mb-10 width-100">
</a>
<h3 class="title-medium-dark size-md mb-none">
<a href="/news/view/00170526.html">Sacha Baron Cohen to Receive Comedic Genius Honor at 2021 MTV Movie and TV Awards</a>
</h3>
</div>
</div>
</div>
</div>
<div class="sidebar-box">
<div class="ne-banner-layout1 text-center">

<div id="mmt-a2ee89a2-4d6c-4cae-abaa-850818733039"></div><script type="text/javascript" data-cfasync="false">$MMT = window.$MMT || {}; $MMT.cmd = $MMT.cmd || [];$MMT.cmd.push(function(){ $MMT.display.slots.push(["a2ee89a2-4d6c-4cae-abaa-850818733039"]); })</script>

</div>
</div>
</div>

</div>
</div>
</section>


<footer>
<div class="footer-area-bottom">
<div class="container">
<div class="row">
<div class="col-12 text-center">
<a href="/" class="footer-logo img-fluid">
<img src="/assets/img/logo.png" alt="AceShowbiz logo" class="/assets/img-fluid">
</a>
<h2 class="title-bold-light">
<a href="/html/aboutus.php" title="About">About</a> |
<a href="/html/faq.php" title="Authors">FAQ</a> |
<a href="/html/terms.php" title="Term of Use">Term of Use</a> |
<a href="/html/privacy.php" title="Term of Use">Privacy Policy</a> |

<a href="/html/contact.php" title="Contact Us">Contact Us</a>
</h2>
<h3 class="title-medium-light size-md mb-10">&copy; 2005-2021 <a href="https://www.aceshowbiz.com" title="AceShowbiz">AceShowbiz</a>. All Rights Reserved.</h3>
</div>
</div>
</div>
</div>
</footer>

</div>


<script>
			if ('serviceWorker' in navigator) {
				navigator.serviceWorker.register('/service-worker.js').then(function(registration) {
					// Registration was successful
					console.log('ServiceWorker registration successful with scope: ', registration.scope);
				}).catch(function(err) {
					// registration failed :(
					console.log('ServiceWorker registration failed: ', err);
				});
			}
			
			self.addEventListener('fetch', function(event) {
			console.log(event.request.url);
			event.respondWith(
			caches.match(event.request).then(function(response) {
			return response || fetch(event.request);
			})
			);
			});			
		</script>
<script type="text/javascript" src="//platform-api.sharethis.com/js/sharethis.js#property=5989b2b57c544f0011665e85&product=inline-share-buttons"></script>

<div id="mmt-0fc19fa5-059c-454d-9432-207b13465843"></div><script type="text/javascript" data-cfasync="false">$MMT = window.$MMT || {}; $MMT.cmd = $MMT.cmd || [];$MMT.cmd.push(function(){ $MMT.display.slots.push(["0fc19fa5-059c-454d-9432-207b13465843"]); })</script>

<script type="text/javascript">(function(){window['__CF$cv$params']={r:'64be92267ee459f2',m:'9ea007fb947c13d1f8a08b538eda5d88db7db5d5-1620433736-1800-AR27SVZZZqddGhVQhY3oQzaI6LoxKF1FoeTxnleLUPATdYobE4Hemr82Q6CuVpeZgvlJ8c/DfLagGXwi4tZUOy/ko31FMqmSy/VAi3xbFa+fRYJp6nnYEjDDT50CA5s6C/08k4YXVg10jgXXjm8hpVs=',s:[0x84b9587f35,0x69f98c2017],}})();</script></body>
</html>
